reverse light switch

Engines, Gearboxes, axles and anything in between

Moderator: BradW

reverse light switch

Postby ross on Tue Nov 24, 2009 10:25 am

I've just been checking the reverse light switch on my gearbox, which didn't seem to be working when I selected reverse. I assumed it was the switch so I removed it to check. If I depress the switch manually it makes contact and works, but when it's installed in the box it doesn't work at all. Anybody got any ideas, is there an adjustment somewhere?
Ross
Locost chassis with Toyota 20 valve blacktop and T50 box.
User avatar
ross
 
Posts: 1076
Joined: Fri Oct 14, 2005 12:33 pm
Location: centurion

Re: reverse light switch

Postby muller on Tue Nov 24, 2009 10:40 am

I think there is a little steel ball that needs to go into the hole to activate the switch that you might be missing. I have a manual at home and will check for you.
Anton

Race car 1: Birkin IRS 4AGE 20v (TLR class B - B10)
Race car 2: Birkin IRS 4AGE 20v (TLR Class B for SO - B20)
Road car: erm.. who cares
User avatar
muller
 
Posts: 1452
Joined: Sat Aug 28, 2004 4:57 pm
Location: Benoni

Re: reverse light switch

Postby ross on Tue Nov 24, 2009 11:17 am

Hi Anton,
I have a copy of the manual that you sent me a while back. I've just been looking through it and I think you may be right about the ball, it doesn't mention it specifically in the text (unless I mised it) but there is one picture where it looks like the guy has a ball in his hand. I have another T50 box here that Andre' gave me I'll have a look at that one and see.
Cheers,
Ross
Locost chassis with Toyota 20 valve blacktop and T50 box.
User avatar
ross
 
Posts: 1076
Joined: Fri Oct 14, 2005 12:33 pm
Location: centurion

Re: reverse light switch

Postby ross on Tue Nov 24, 2009 11:55 am

Ok,
I checked both gear boxes and there is no ball. Anton do you knopw what size the ball is?
Cheers,
Ross
Locost chassis with Toyota 20 valve blacktop and T50 box.
User avatar
ross
 
Posts: 1076
Joined: Fri Oct 14, 2005 12:33 pm
Location: centurion

Re: reverse light switch

Postby ross on Tue Nov 24, 2009 3:29 pm

Problem solved, I checked the part numbers in the manual you sent me Anton and found that the ball for the reverse light switch has the same part number as the other detent balls. I pinched one of them from the other gearbox and fitted it, the switch is working perfectly now. Strangely enough the ball is 3/8th inch, I should be able to get hold of one from bearing man.

Ross
Locost chassis with Toyota 20 valve blacktop and T50 box.
User avatar
ross
 
Posts: 1076
Joined: Fri Oct 14, 2005 12:33 pm
Location: centurion

Re: reverse light switch

Postby BuzzFuzz on Mon Mar 17, 2014 3:59 pm

Hi Guys,

My switch on my T50 seems to be broken :cry: . I pulled the switch out and the ball is in there. I've checked with a multi-meter and pushing the switch in the circuit does not close. :evil:

Going to pop by Midas after work today. Hope they have stock... something tells me its not a common part so probably wont be so lucky.
Jethro

1) Scratch build - 20V blacktop & T50 box (done... but always tweaking)
User avatar
BuzzFuzz
 
Posts: 158
Joined: Tue May 22, 2007 7:23 pm
Location: Edenvale

Re: reverse light switch

Postby BuzzFuzz on Mon Mar 24, 2014 12:45 pm

OK so went to Midas and Autozone, they ordered parts and they were wrong... I even had the switch with me to show them.
Went to a small Indian spares shop around the corner from me and he said one wont easily find the part due to the age :(
But we looked through the spares booklet and he found the switches that had the same thread and looked similar. Eventually found one part... from a Nissan, RS104. Fits perfectly and works 8)

So fitted it, drained the gearbox... Filled it with nice new oil. (Little confused as to where the level should be) there is a smaller bolt :cry: about 10cm above the drain plug that I filled the box until it poured out there.

Now I see the t-50 box is leaking a little out where the prop shaft goes in :(

Also checked the Ford Escort MK1 4.11 Diff and filled that... its leaking plenty out the front :| (Proshaft end).
Jethro

1) Scratch build - 20V blacktop & T50 box (done... but always tweaking)
User avatar
BuzzFuzz
 
Posts: 158
Joined: Tue May 22, 2007 7:23 pm
Location: Edenvale

Re: reverse light switch

Postby davew on Mon Mar 24, 2014 3:08 pm

BuzzFuzz
I would bet that you slightly over filled the trans. I would just check the rear seal area after a little road time to see if it continues to leak. I hope your nice new oil is GL-4 and not GL-4/GL-5 or GL-5. The old brass design T-50 synchros do not like anything but GL-4. Or you will be looking at rebuilding that trans. Been there, done that. Dave W
davew
 
Posts: 5
Joined: Fri Jul 26, 2013 9:22 pm
Location: USA Michigan

Re: reverse light switch

Postby BuzzFuzz on Mon Mar 24, 2014 5:00 pm

Dave

Thanks for the heads up :) , I've got a pretty decent Semi-Synthetic 75W-90 with an API MT-1 spec that the box seems to call for. But it is a GL4/GL5. I'll see what else I can get my hand on...

Maybe Titan Cytrac MAN synth 75W80 (GL4) more for truck boxes, better fuel economy and tested to 600'000km successfully 8) with fantastic wear results.

But will definitely look at changing to a GL4.
Jethro

1) Scratch build - 20V blacktop & T50 box (done... but always tweaking)
User avatar
BuzzFuzz
 
Posts: 158
Joined: Tue May 22, 2007 7:23 pm
Location: Edenvale


Return to Running Gear

Who is online

Users browsing this forum: No registered users and 11 guests